Visio 2016 search is not working

Actually I have no idea how this works, probably I need to investigate deeper, but now I have not enough time tor that. So the issue was with the search, like here or here. Search simply was not working. I run win10 + Visio 2016 pro, all x64. I downloaded Azure and AWS  stencils, put them  to My Shapes folder under Documents and It sis not work.

I spent huge amount of time poking around, I was rebuilding indexes, restarting services, copying files. I even looked into the index with PowerShell. Files were there but Indexing did not work.

And as last resort I just copied and pasted all the files inside of the same directory:
C:\Program Files\Microsoft Office\root\Office16\Visio Content\1033. And suddenly it worked!

So the workaround was to:

  1. Copy all stencil files you need to a C:\Program Files\Microsoft Office\root\Office16\Visio Content\1033
  2. Select them all, copy (CTRL+C) and paste (CTRL+V) them once again in the same directory

And they immediately appear in the search! Don’t ask me why.

visioFilesCopied

visioFilesCopied2

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s